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Preparing data for analysis

Open E-DataAid
The E-DataAid application may be used to examine your data and prepare it for export to a tab-delimited text file so that it may be read into another application such as Excel.  This step guides you through the opening of the E-DataAid application.
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Startup program for preparing data for statistical analysis
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1. From the Start Menu, select Programs, E-Prime, and E-DataAid.

The E-DataAid application does not open to a specific data file or to a blank file.  The only active tool button is the Open button.
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Open a data file
This step guides you through the location and opening of the data file to be used in this tutorial.  Note you MUST run the Merging Data Files tutorial before this one to create the Merged Tutorial Data.emrg file.
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Open the merged file that you want to prepare for analysis
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Select the Open command from the File menu.

The Admin Open command allows the user to set security options.

2. In the Open dialog, Navigate to the Data folder in C:\My Experiments\Tutorials directory.

3. Select the Merged Tutorial Data.emrg file.
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The Merged Tutorial Data.emrg file contains data from 5 subjects participating in the Tutorial experiment.
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4. Click Open.
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[image: image12.bmp]The spreadsheet contained within the selected file will be displayed.

[image: image13.png]Open

Lookin [ D3

g B Tuoast

[€) Tutorial1-1
lE) Tutorial2:1
) Tutorial31
[E) Tutoria41

Fie pame:  [Merged TutorelData pen
Files of ype:  [E-Prime data fils *edat- emg) E Cer

2







[image: image14.png]atai

SEIES

@! Merged Tutorial Data
Fle Edt View Icos Hep

e E PR EE R E )

ExperimentName| Subject Session| Date| Group| RandomSeed| Time| Block| BlockList| BlockList.Cycle| BlockList.Sample| PracticeMode| Procedure[Block]| Ru2.
1 |Tutorial 11 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
2| Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
3 | Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
|4 | Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
5 | Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
B | Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
7| Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
8 | Tutorial " 1 04-1 |1 1543083233 |14:511 1 1 1 no BlockProc Ble
9 | Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
10| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
11| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
12| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
13| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
14| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
15| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
16| Tutorial 2 1 04-1 |1 1634241382 |14:53]1 1 1 1 no BlockProc Ble
17 | Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Ble
18 Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Ble
20| Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Bl
121 ] Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Blc
22| Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Ble
123 Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Blc
24| Tutorial 3 1 04-1 |1 1693273622 |14:53]1 1 1 1 no BlockProc Ble
125 Tutorial 4 1 04-1 |1 1747003627 |14:541 1 1 1 no BlockProc Blc
|26 | Tutorial 4 1 04-1 |1 1747003627 |14:541 1 1 1 no BlockProc Ble
127 | Tutorial 4 1 04-1 |1 1747003627 |14:541 1 1 1 no BlockProc Blc
128 Tutorial 4 1 04-1 |1 1747003627 |14:541 1 1 1 no BlockProc Bl
. j o

Filters |

[TargetAcC =1

il >
ForHelp, press F1 [Rows Displayed: 38 ()






Filter Data 
This step guides you through the filtering of the data to include only those trials on which the subject responded correctly.

Create filter to select which trials should be included in the analysis
Open filter dialog
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Click the Filter tool button to display the Filter dialog.
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The Filter dialog may also be displayed using the Tools menu.
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Select variable to be used in filter
2. Select Target.ACC in the Column name list and click the Checklist button.
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The Target.ACC variable contains the accuracy of the subjects response for each trial (0=incorrect, 1=correct).
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Select values to be included in analysis
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On the Checklist page of the Filter dialog, check the checkbox next to “1” (click on it) to include only correct responses.

Apply filter
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Click OK to apply the filter.

The display will be refreshed to show only correct answers, and Target.ACC=1 will be listed in the Current filters field on the Filter dialog.

5. Click Close in the Filter dialog to dismiss it.
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The Filters Bar at the bottom of the display lists Target.ACC=1 as an active filter.   The Target.ACC column header will be displayed in white to indicate a filter is now in place.




Edit Cells

[image: image31.jpg]This step illustrates how to edit the values within the spreadsheet, and how E-DataAid displays altered data.  For this example, we incorrectly assigned one of our subject numbers, and need to change the subject number for that subject. 

Editing a cell to fix an error in the data file
Select cell to edit

1. Click the first cell under the Subject column to select it.

Make the change

2. Change the Subject number in this cell from “1” to “11” by typing directly in the cell.

3. Press <Enter> or click in another cell to accept the edit to the Subject number.

E-DataAid displays all alterations to data in red.  All cells in the Subject column associated with this session of data have been modified to display “11” in red.  




Analyze Data

This step illustrates how to use the Analyze command to create a table of means for reaction time by condition.

Start analysis

1. From the Tools Menu, choose the Analyze command, or click the Analyze tool Button.

The Analyze dialog will be displayed.

Pick title for analysis

2. In the “Name:” field, type “Mean RT by Condition” as the title for the analysis.

Select within subject variables to put in columns of data table

3. In the Variables list, click NameGender, and drag it to the Columns list to designate it as a column.

4. Designate PrimeType and PrimeGender as Columns.

This will create a cell per condition according to the levels of the independent variables (2 x 2 x 2).

Select between subject variable(s) to put in rows of data table

5. Click Subject in the Variables list and drag to the Rows list.

Select dependent variable to put in data table

6. Click Target.RT in the Variables list and drag to the Data list. 

Note that you may double click on a variable to change the stat.

7. Click Run
This will display a Table dialog showing the mean reaction time per condition for each of the subjects.  Because we filtered for only correct responses, and because we have only a few subjects, some of the cells are empty.






Export Table of Means to StatView

In this step you will export the table of means to a text file for import into StatView.

Open Options dialog box for setting export preferences

1. Click the Options button at the bottom of the Table dialog.

The Options dialog is displayed in order to set the options for export.

Change setting to export to Statview program

2. Click the radio button next to StatView to set the default options for export to StatView, and Click OK.

Export the table

3. Click the Export button at the bottom of the Table dialog.

The Export dialog is displayed with the default settings for export to StatView.





Export to StatView continued . . . 

4. Click OK in the Export dialog to export to StatView.

Name and Save Exported Data File

5. In the Export As dialog navigate to C:\My Experiments\Tutorials\ Data folder type “Table of Means” in the “File Name:” field.

6. Click Save.

The table of means will be saved as a text file in the Data folder.

7. Close the Table and Analyze dialogs.

You could then load the data into the statistics program for future analysis.






Export Data to Text

In this step you will export the displayed spreadsheet data to a tab-delimited text file which may then be imported into Excel.

Export entire data file

1. Select the Export option from the File Menu.

The Export command exports the currently displayed spreadsheet data to a text file, including any filters currently applied (i.e., Target.ACC=1).

Select Excel as format

2. In the Export dialog, set the “Export to:” field to Excel.

The appropriate settings are already defined, so all of the remaining fields remain inactive.

3. Click OK.

Name exported file

4. In the Export As dialog, navigate to the C:\My Experiments\Tutorials\ Data folder type “Exported Tutorial Data” in the File Name field.

5. Click Save.

The data will be exported to a tab-delimited text file  (Exported Tutorial Data.txt) which can easily be imported into Excel.







Creating an Excel Plot 

This step illustrates how to use the Analyze command and a table of means for reaction time by condition to create an Excel Plot.

1. Continue using the Merged Tutorial Data.emrg file to create the excel plot.

Start graphical analysis

2. From the Tools Menu, choose the Analyze command, or click the Analyze tool Button.

The Analyze dialog will be displayed.

Select variable(s) to put along X-axis of the graph

3. In the Variables list, click PrimeGender, and drag it to the Columns list to designate it as a column.

Select variable(s) to put in the legend of the graph

4. Click NameGender in the Variables list and drag to the Rows list.

Select the dependent variable to put in the graph

5. Click Target.RT in the Variables list and drag to the Data list. 

Note that you may double click on a variable to change the stat.

6. Click Run
This will display a Table dialog showing the mean reaction time per condition for each gender.






Creating an Excel Plot continued…

Select Excel Plot as export format

7. Click the Options button at the bottom of the Table dialog.

The Options dialog is displayed in order to set the options for the excel plot.

8. Click the radio button next to Excel Plot to set the default options, and Click OK.

9. Click the Plot Excel button at the bottom of the Table dialog.

After viewing the Excel plot, close all the programs

10. Exit Excel (click Exit in the File Menu).

11. Close the Table and Analyze dialogs.

12. Exit E-DataAid without saving (click Exit in File Menu).







Import Text File into Excel

In this step, you will import the text file containing the merged data into Excel.

Open Excel to import whole data file

1. Open Excel.

Use Open command to start import process

2. From the File Menu in Excel, select Open.

Locate file to import
3. In the Open dialog, navigate to the folder containing your Exported Tutorial Data.txt file (C:\My Experiments\Tutorials\

Data).

Be sure the Files of Type field in the Open dialog is set to “Text Files.”


4. Select Exported Tutorial Data.txt.
5. Click Open.

Use Import Wizard to finish process

6. In the Text Import Wizard dialog, click Finish.

The Exported Tutorial Data.txt file will be opened in an Excel spreadsheet..  Header information is included listing the path and filename for the imported data file, a notice that the file contains edited data, and the filter placed on the data when it was exported (Target.ACC=1).

7. Exit Excel (click Exit in the File Menu).
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